ﬁ LATTICE

TECHNOLOGY

Lattice Technology

New Product Feature Highlights

June 2011 Product Release



IS LATTICE
LR TECHNOLOGY

XVL Studio Ver. 10.0a



Fa== LATTICE
TECHNOLOGY

General Features



[S-1] Exporting IGES from V-XVL Ver.10 2= LATTICE

Description: IGES file is exported from V-XVL Ver.10 format.
Menu: [File] > [Export]

-
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Bike_Enginexv2 Bike_Engine.igs

V-XVL Ver.10 IGES

* IGES format is exported from P-XVL and V-XVL Ver.10 format only.
IGES format is not exported from V-XVL Ver.9 format.
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[S-2] Customizing Toolbars

Description: You can create your own customized toolbars.

Menu: [Tools] > [Customize]

Customize E

Toolbars COITIITIEIHdSl
Categories: Commands: /
[ Mew P

Edit
View E| & Open.. { j
Tools. Close ‘> - — s ) =
Evaluation I save Eﬁ ﬁ E EE £ he B o a |§') El o El IE' - -
Human
Animation Save fs...
Window i Auto Update. .. =
Selected Command: —

Dezcription | /\ l

/ | Oose | Customized toolbars

L are saved in the
/ layout setting file.
New toolbar is created by

dragging & dropping the
command icons.

Layout.cfg
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[S-3] Import the Tree in the Same Order Fsay LATTICE

Description: When the components are selected and dragged and dropped from the original tree,
components are created in the same order as the original tree.

Assembly Tree

]

E-[#]El TT-4000Engine_process

- [ TT-4000 Engine Assy

...a TT-3310 Cocling Fan A
B[] &3 TT-3311 Cooling Fan B

i-[w] B3 S6:l0:d2 One Way Cluch
H-[w] B STT36 Engine Throttle
H-[w] B 5638 Mut

£
£
£
- [v] &3 53.0:10 Bolt %l —
b
b
£

Structure Panel

]|

Q-4 - XBE 2R BB - EH

=1-{3 {All [Assembly-Path Authoring]:

E@ 1 Process-1
{57 1:1 STT36 Engine %1
[1-57 1:2 52.6:6 Cap Bolt %11
-5 13 S2.6:6 Cap Bolt %12
57 1:4 S26:6 Cap Bolt %13
57 1:5 52.6:6 Cap Bolt %14
[1-57 1:6 52.6:6 Cap Bolt %15
@57 17 S2.646 Cap Bolt %16

#-%7 1:8 S2.6x6 Cap Bolt %17
-7 1:9 52.6x6 Cap Bolt %18

Copy & Paste

57 1:10 52646 Cap Bolt %19
57 111 52.6:6 Cap Bolt %20

E-57 1:15 5645 Nut %1
&%/ 1116 53.0:10 Bolt %3
-5 7 1:17 53.0:10 Bolt %4

&7 1:12 TT36 Needle %1
II &%/ 1:13 TT-3300 Cocling Fan %1

[-57 1:14 TT-4313A Clutch Shoe %1

Components are created
in the same order as the
original tree.

In Ver.9.2, components were

< [ s
"B Assembly Tree " L= |6 5n.. 1B Pr.. [B D [ Ki. | created in the random order.
June 2011 Lattice Technology, Inc. 6
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Auto Update Features



[S-4] Updating Selected Assembly P LATTICE

TECHNOLOGY

Studio Standard

Description: You can update only specified sub assembly.
. Studio Pro

Menu: [File]: [Replace Assembly]

Replace Assembly [1/2] [E=B(EcR ==

Target Assembly: Selected Updated /

Feplacement Object 3L

.Technical\Mew Featuresh20110B01AT esthduto_update TT-3401 w2 D
Part-matching Targets: . /

List Edit

lllustration

¢ Process Part ¢ Disassembly Part

Fart-matching Baze Location:
& Coordinate system origin+~ © Center of bounding box

Fart-ratching Rules:

* Pait Name Only selected
" Properties .
assembly is updated.

Section; | CAD"

 CAD D
" SV File

| |

[~ Specify the number of letters for name/property comparison

|5 letters

[ Match parts within the specified distance DeSlgn Change |S
100 fram the bage location app“ed to the selected
Part-matching Duplicate Parts: assem bly Only
' Do not conzsider parents

" Consider parents

 Select anly parts with matching parents

Ok I Cancel |
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[S-5] Updating Process Tree and Disassembly Tree

&& LATTICE

TECHNOLOGY

Description: Both Process Tree and Disassembly Tree are updated simultaneously.
[File]: [Auto Detection and Update]

Menu:

Auto Detection and Update [1/2]

Edited =L
resh 201106014 T esthauto_update T T-4000E ngine_BOM_process. w2 J

Part-matching T argets:

& Process Part " Digagsembly Part

Part-matching Base Location:

' Coordinate systemorigin~ ¢ Center of bounding box

Part-matching Rules:

& Part Name
 Properties
Section: | TAD" LI Propert_l,l:IDenSil_'r' 'I
& CADID
" 5% File

| |

[~ Specify the number of letters for name/property comparizan

|5 letters

[ Match parts within the specified distance

I-I oo fram the base location

Part-matching Duplicate Parts:
™ Do not consider parents
' Cansider parerts

" Select anly parts with matching parerts

OF. I Cancel

Disassembly Tree

II»

Structure Panel

&% X HEE-
-4000Engine_Rev2i

Update

Studio Standard

. TT-4000 Engine Assy
- 25TT36 Engine
B3 3 52.6w6 Cap Bolt %7
Bl-43 3 52.6x6 Cap Bolt %6
B3 3 52.6x6 Cap Bolt %5
El-63 3 52.6x6 Cap Bolt %210
El-43 3 52.6x5 Cap Bolt %9
B3 3 52.6x6 Cap Bolt %8
B
-
B
£
B
E

)3 3 5266 Cap Bolt %4
i@ 3 52.6x6 Cap Bolt %2
q-& 3 5266 Cap Bolt %1
o453 3 52.6x6 Cap Bolt %23
i-i3 4 TT36 Needle
1-].9 5 TT-3300 Cooling Fan
- -3 6TT-3310 Cocling Fan A
- 7TT-3311 Cooling Fan B
-6 8 TT-4313A Clutch Shoe

m

|Iﬂ Sh.. |~L|:| Pro.. &% Dis.. ﬂ Kin... |

Studio Pro
List Edit
Illustration
Process Tree
Structure Panel
X E ==
= B il Thssembiy-Fath Authorind  UPdated

£

B
B
£
£
£
£
£
£
B
B
B

™

- 1 Assembly of Engine

15,7 1:1 Set Engine body

i) 1.1 Assembly of Cooling Fan
s 1:2 Attach Cooling Fan Assembly
52 1:3 Fasten Nut 56.4 x5

s 1:4 Attach Clutch Shoe

75,2 1:5 Fasten Bolt 53.0x10

752 1:6 Insert One Way Cluch 56 x10
752 1:7 Attach Needle

s 1:8 Attach Engine Throttle

752 1:9 Fasten Nut 56 8

g2 1:10 Fasten Cap Bolt 52.6 x 6
]ﬁ 1:11 Fasten Cap Bolt 52,6 x 6 (radiator)
----- %2 1:12 Turn over Engine assembly

B Lay..

| Sn.. 1B Prow. |& Dis.. [£2 Kin.. |

June 2011
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[S-6] Matching Option for Duplicate Parts ri=y LATTICE

Description: Specifies the method of judgment if two or more matching parts are

found during auto detection.
Menu: [File]: [Auto Detection and Update]

Studio Standard

Studio Pro
List Edit

lllustration

Description

Auto Detection and Update [1/2] ==
Edited xL:
rez 20110601 A TesthAuto_updatehTT-4000E ngine_BOM_process.we? .
- sreenE | Option
Part-matching T argets:
 Process Part " Disassemhbly Part Do not consider parents

Part-matching Base Location:

* Coordinate spstemangin ¢ Center of bounding bos

Part-matching Rules:

The parts that are closest to each other
from the base location are judged to match.
The parents of the parts are not considered.

+ Part Mame -

£ Properties Consider parents
Section; |'CAD" J Property: | Density

" CADID

" CSV File

| El

[ Specify the number of letters for name/property comparizon

If parts with matching parents are found, the
parts that are closest to each other from the
base location are judged to match.

If no parts with matching parents are found,
the parts that are closest to each other from
the base location are judged to match.

3 It .
i Select only parts with
[~ Match parts within the specified distance .
matching parents
100

fTata)

Fart-matching Duplicate Parts:

" Do not congider parents

If parts with matching parents are found, the
parts that are closest to each other are
judged to match.

* Consider parents

™ Select only parts with matching parents

| )4 | Cancel

June 2011 Lattice Technology, Inc.
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[S-7] Visualizing Clearance in Interference Check ri=d LATTICE

Description: Clearance is visualized in color map while checking interference.

Menu: Edit Panel > [Interference Result] > [Display Options]

Interference v Interference [ Interference v Interference W

Faint; area area 2 intersection .
distance

+

Contact Contact
v
I area o area 2

= Clearance Vv Clearance = Minimum clearance
area 1 area 2 distance

Minimum gap 7 Minimum gap = Minimum gap
areal M area 2 M distance

¥ Display color map:  Aceraco: |2 mm

v Show adiacent clearance areas

<l

Calar Bar: Impaort... Expart... | Initialize: |

Studio Pro

Only interfered areas
are displayed in color
map.

Adjacent clearance
areas are also displayed
in color map.

I Interference Display Option EI
Interference [ Dizplay 1 ¥ Display 2
Part I Highlight I Highlight 2
I Fit1 I Fit 2
[ Semitransparent 1 v Semi-transparent 2
S E )

interference

Clearance areas = OFF

Clearance areas = ON

June 2011

Lattice Technology, Inc.
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[S-8] Saving Layout in Annotation View Iy LATTICE

TECHNOLOGY

.. _ _ _ _ Studio Standard
Description: Part layout is saved in the Annotation View.
. Studio Pro
Menu: [Tools] > [Customize]
Annotation
View
Edit Panel
B X | h e
Mo | Mame | Comment |
1 Anrniotation-1 Azzembly check of Cooling Fan
/ 2 Anniotation-2 Tightening check
[ Options =]
Add Annaotation Wiew
IV B eqister visibility
! ¥ FRegister lapouts
< Parts layout is saved and
| applied in the annotation Shiow Annatation View
view. v Heflect vizsibilit

v Apply layout
Dizplay Properties
v Mo
v Mame
¥ Comment

June 2011 Lattice Technology, Inc. 13



[S-9] Prevent to Move Dimension Text Position ez LATTICE

Description: By changing the setting, dimension text position is not moved.
Settlnq File: DIMENSION_FIX TEXT = TRUE

By changing the setting file,
you can go back to the
behavior of previous version.

Dimension texts are moved with leader Dimension texts are not moved (same
lines (default behavior). behavior as Ver.9.1 or earlier).
DIMENSION_FIX_TEXT = FALSE DIMENSION_FIX_TEXT = TRUE

January 2011 Lattice Technology, Inc. 14
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Parts List / lllustration



[S-10] Moving Parts in Radius Direction Fi=q LATTICE

Description:; Parts can be moved in radius direction.

Menu: [Tools] > [Move Part]

Specify the
rotational face

[ Mowve Part Ii“ﬂ”é]
Edpuedztiml M armnal ;I
Doge, |Pat | selected (5)
Euazgtinn IFial:Iius direction of ratational face ;I w\

TECHNOLOGY

Selected parts move in
the radius direction of
specified rotational face.

QQ\

R / Drag to the
» radius direction

Use “Radius direction of
rotational face” option.

June 2011

Lattice Technology, Inc.
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|S-11] Finding Objects with Multi-Filter

Description: Multiple filter conditions are specified to find objects.
Menu: [Edit] > [Find]

June 2011

Condition Properties \E\
v Condition 1
- Find EI@ Section: "Configuratior = | Property: |1 ECMN Mumbe =
Object Type: |.~'—‘n.ssem|:u|_l,l.»’|:uart j W alue: (% Fized " Range
2333 a - oo
Find by |Name ﬂ | | |
[ Exclude thiz condition
Narne: | = ¥ Condition 2
[ Use extended spntas *« sND O OR
Find rew | Refine | Section: Configuratior * | Property. |1 Revision =
2 Walue: {* Fived " Range
Multi-conditions... |A |D |1|:“:|
[~ Exclude thiz condition
Rezult [35] :
hame Lipe Froperty List:
403124001 [Simple] %3 Part Property edit ik
403124001 [Simple] %4 Part Mame Type Value -
403124001 [Simple] %1 Part Material2 Tedt .
403130007 [Simple] Part VREME”E Tog .
4031240010 [Simple] %2 Part Densi Tedt 0.283 LN
403162007 [Defaul] %3 Part \ ensity 43 (g
403124001 [Defaul] %3 Part [ | DensUnit Text lbfin®3
4031 25001 (D sfaul) Part AECN Number Text 2999
162261001 [Default) Fart & Revision Text * /
A Revision Text | B I
Cloge A Change Descrip,..  Text
A Change Descrip.,.  Text
A Chanae Bu Teut IFF 2
1 1 | »

Lattice Technology, Inc.

ﬁ LATTICE
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Up to five conditions
are set to find objects.

Properties of filtered
objects can be edited
all at once.

17




[S-12] Exporting SVG lllustration with Raster Image  Fa=d LATTICE

[llustration

Description: SVG illustration is exported with raster graphic image.

Menu: [File] > [Export] > [lllustration File]: [Illustration File Output] tab

[llustration Output dialog All raster image is

Delete shapes less than I-I rim exported Wlth SVG
[T Convert lines to curves I||UStl‘atI0n

¥ Connect as many lines as pozsible

[T Circle notes

¥ Export image files of selected parts at the same time [S¥G only)

Expart Target: ISpecifiedparts YI Selectedﬂ]l

/ Preview... | Export... I Cloze |

/

Either all parts or specified
parts are exported with raster
image.

Only specified parts are
highlighted with raster image
after changing the part color in
3D graphics.

*Only SVG format is supported.

June 2011 Lattice Technology, Inc. 18



[S-13] Changing the Fitting Method of Image/lllustration Export ~ Fsad LATTICE

TECHNOLOGY

Description:

By changing the setting, you can export image/illustration in the method lllustration
of previous version.

Setting File: FILE_EXPORT_IMG_ADJUST_VIEWSIZE = FALSE
ILLUST_EXPORT_ADJUST_VIEWSIZE = FALSE

Default behavior

All visible area is
included in
image/illustration.

Imagelillustration
is fit in vertical
direction.

June 2011 Lattice Technology, Inc. 19
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[S-14] Equipment/Tool List P LATTICE

Description: Tools and equipments are displayed and edited in the list. Slilielio [FIt

Menu: Edit Panel > [Equipment/Tool List]

Assembly Tree

- [7]F Equipment_Group
ﬂ Desk
B[l Tool_Group
,f" Impact_33_150
j" owrench_33
.f" owrenchld 18

Equipment/Tool list is
exported in CSV format.

Equipment/Tool List /
Edit Panel
E"‘ L UEE N |
f -
M | Name | Type | Comment | Description || ; E:
1 Deszk Equipment Wwork, Desgk, B
2 Impact_33 150 Toal Impact wrench with zocket M33 « 150 AL,
3 owrench_ 33 Toal Owench k33
4 owrenchl6_18 Tool Owench kM16-18
Equipment/TooI pr_operties Equipment/Tool CSV
are edited on the list.
Par.. |E 4s.. |[El Me.. |[E Di.. |[E] Pr. Eq.. |Ef Dis.. |[E Dis.. |l An.. |BE Edi.. | @ Int.. |ﬂ Kin... |

June 2011 Lattice Technology, Inc. 21



[S-15] Improvement of Part/Assembly Snapping

Description: Assembly snap is performed more efficiently.

ﬁ LATTICE

TECHNOLOGY

Studio Standard

Studio Pro
Menu: [Tools] > [Shap Part/Assembly]
List Edit
Example
STEP 1 STEP 2 Result
Constraint: 1 Constraint: 2
(continuation snap)
| I
Up to Ver. 9.2
Select edges Select edges Pop;sczl;irteiocnh %ngzrsn'ebm
Constraint: 1 Constraint: 2
(continuation snap)
Ver. 10.0a ||» II»
Posture and position
Select edges Select edges are applied.




[S-16] Trace Line in Process Report

ﬁ' LATTICE

TECHNOLOGY

Description: Animation trace lines are displayed in the process report.

Studio Standard

. . Studio Pro
Menu: Edit Panel > [Process List]: [Output Report]
Animation trace line is
shown in the images.
x .. Process Report (Excel)
il
Attach the Clutch &
Attach Clutch Shoe to the
1:4 [Shoe 30 assembly. -
June 2011 Lattice Technology, Inc. 23



[S-17] User Event for Process Animation 2= LATTICE

Studio Standard

Description: User event is defined for process animation.

M [Animation] > [Edit E { Studio Pro
- nimation| > | ven
vienu. XVL Player
B vt Propetics e e
M arne: IEvent-'I
Type: |Key Down =l star selectinnl
Kew/Object: I-""\
Action:  Apimation % Process &nimation
IPla_',' LI
Ok Cancel
/

AN
Fausze \

Play Reverze

Cle Each action for Process animation is
Previous process animation played from defined user
’E‘;*'E”t control is selected. event on XVL Player.

[{]u]

June 2011 Lattice Technology, Inc. 24



[S-18] File Import Enhancement Fz=d LATTICE

Description: When part is replaced, part name and its properties are also replaced.

Menu: [File] > [Import] > [Geometry File]

Part name is replaced.

Import Geometry File dialog /

Import Method: B 52.6:6 Cap Bolt %4 &3 526:6 Cap Bolt %4
" Add to model e[ B 52.6x6 Cap Bolt % [+ [#] & 52646 Cap Bolt %
[T Specify how o import & part with e zame name : B3 526:6 Cap Bolt Selected B 52566 Cap Bolt %
- [ B 5260 Cap Bolt %3 [+ [#] & S52.6x6 Cap Bolt 7
7 Add to selected assembly Ed TT36 Meedle .
I add assembly as link EMmE 3 77-3300 Cooling Fan - [ TT-3401 Cooling Fan
. @[] & TT-3310 Cooling Fan m» B “3310 Cooling Fan A
% Replace selected part P ) ]
- [w] i3 TT-3311 Cooling Fan B - [#] &3 TT-3311 Cooling Fan B

Imipart Structure: Bl TT-43134 Clutch Shoe
v Layer v Process W Dizaszembly ee E 56,435 Mut

m- [ B9 53.0:10 Bolt %2

m- 188 53.0:0 Bolt %1

-[Z1 & TT-43134 Clutch Shoe
[ 56445 Nut

[#&3 S3.0:0 Bolt 362

[ E3 53.0:0 Bolt %1

Froperty List: Property List:
Mame | Type | Value MName | Type | Value |
Description Text Cocling Fan | Description Text poling Ean
Partho Text TT-3300-000 Parthlo Text TT-3401-000
UNIT_OF_MEASURE Text - none - UMNIT_OF_MEASURE Text ﬂ - none -
Required setting: Property value is

FILE_IMPORT_PART_REPLACE_MODE =1 replaced.
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[P-1] Customizing Menus rzzd LATTICE

Description: You can enable/disable menus by setting the menu file.

Menu.csv
Sl [0 R A S LT ~ 1 | |STATUS IDC_XT_TOOLBAR FALSE
\ IJ‘ EE STATUS IDC_XT_TREEDOCKWIN  TRUE
STATUS ID_FILE_PROP FALSE
Assembly Tree display is A STATUS 1D _EDIT_PROP TRUE
disabled. Menu.csv
File » Menu file is specified in two methods.
Edit | =
f*"‘l' ' Server Menu File
cosoton |8 Commaepal Specify the menu file using
Help VT OPT_MENU_FILE among the Options
Switch to View Mode Property edit is disabled. properties set upon startup.

Client Menu File
Put the menu file in the following location.
<Installation_directory>\Env\Menu.csv

Display All

=

* For more information, see “XVL_Player_MenuFile.pdf’ that locates under
<Installation_directory>\Doc folder.

June 2011 Lattice Technology, Inc. 27



I LATTICE
ey TECHNOLOGY

[P-2] Process Animation Text Alert

Description: Text alert is displayed during process animation.

- Check the tightening of bolts before next step )

After clicking the text

\ Text alert is displayed alert, text alert will be
during the process step. disappeared and

proceed to next step.

* Text alert is edited in XVL Studio Ver.9.2a
or later.

June 2011 Lattice Technology, Inc. 28
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XVL BOM Assembler Ver. 1.2



[B-1] Process Import/Export Option £ b

Description: XVL file is created with process tree information. SIELESE
Process tree information is exported to XML file.

Process Tree

XML
- Assembly structural tree
- Process tree |
+
Import
Export
XVL part files XVL assembly model

* Process option is required.

June 2011 Lattice Technology, Inc. 30
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[P-1] Customizing Menus rzzd LATTICE

Description: You can enable/disable menus by setting the menu file.

Menu.csv
Sl [0 R A S LT ~ 1 | |STATUS IDC_XT_TOOLBAR FALSE
\ IJ‘ EE STATUS IDC_XT_TREEDOCKWIN  TRUE
STATUS ID_FILE_PROP FALSE
Assembly Tree display is A STATUS 1D _EDIT_PROP TRUE
disabled. Menu.csv
File » Menu file is specified in two methods.
Edit | =
f*"‘l' ' Server Menu File
cosoton |8 Commaepal Specify the menu file using
Help VT OPT_MENU_FILE among the Options
Switch to View Mode Property edit is disabled. properties set upon startup.

Client Menu File
Put the menu file in the following location.
<Installation_directory>\Env\Menu.csv

Display All

=

* For more information, see “XVL_Player_MenuFile.pdf’ that locates under
<Installation_directory>\Doc folder.

June 2011 Lattice Technology, Inc. 32
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[P-2] Process Animation Text Alert

Description: Text alert is displayed during process animation.

- Check the tightening of bolts before next step )

After clicking the text

\ Text alert is displayed alert, text alert will be
during the process step. disappeared and

proceed to next step.

* Text alert is edited in XVL Studio Ver.9.2a
or later.

June 2011 Lattice Technology, Inc. 33
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XVL BOM Assembler Ver. 1.2



[B-1] Process Import/Export Option £ b

Description: XVL file is created with process tree information. SIELESE
Process tree information is exported to XML file.

Process Tree

XML
- Assembly structural tree
- Process tree |
+
Import
Export
XVL part files XVL assembly model

* Process option is required.

June 2011 Lattice Technology, Inc. 35



Questions?

June 2011

= T Am

support@lattice3d.com
+1.415.274.1670
+1.415.274.1671
www.lattice3d.com

Lattice Technology, Inc.
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